[or-cvs] [tor/master 3/7] Give rep_hist_exit_stats_history() a better name.
nickm at torproject.org
nickm at torproject.org
Mon Aug 16 01:18:13 UTC 2010
Author: Karsten Loesing <karsten.loesing at gmx.net>
Date: Sun, 15 Aug 2010 14:15:58 +0200
Subject: Give rep_hist_exit_stats_history() a better name.
Commit: 69545efbafaf55f5d6f768268eb73b60547acd64
---
src/or/rephist.c | 4 ++--
src/or/rephist.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/or/rephist.c b/src/or/rephist.c
index 63e602d..b6a19d4 100644
--- a/src/or/rephist.c
+++ b/src/or/rephist.c
@@ -1913,7 +1913,7 @@ rep_hist_exit_stats_term(void)
/** Return a newly allocated string containing the exit port statistics
* until <b>now</b>, or NULL if we're not collecting exit stats. */
char *
-rep_hist_exit_stats_history(time_t now)
+rep_hist_format_exit_stats(time_t now)
{
int i;
uint64_t total_bytes = 0, threshold_bytes, other_read = 0,
@@ -2034,7 +2034,7 @@ rep_hist_exit_stats_write(time_t now)
log_info(LD_HIST, "Writing exit port statistics to disk.");
/* Generate history string. */
- str = rep_hist_exit_stats_history(now);
+ str = rep_hist_format_exit_stats(now);
/* Reset counters. */
rep_hist_reset_exit_stats(now);
diff --git a/src/or/rephist.h b/src/or/rephist.h
index dfdce4e..f655500 100644
--- a/src/or/rephist.h
+++ b/src/or/rephist.h
@@ -68,7 +68,7 @@ void hs_usage_free_all(void);
void rep_hist_exit_stats_init(time_t now);
void rep_hist_reset_exit_stats(time_t now);
void rep_hist_exit_stats_term(void);
-char *rep_hist_exit_stats_history(time_t now);
+char *rep_hist_format_exit_stats(time_t now);
time_t rep_hist_exit_stats_write(time_t now);
void rep_hist_note_exit_bytes(uint16_t port, size_t num_written,
size_t num_read);
--
1.7.1
More information about the tor-commits
mailing list