[tbb-bugs] #28329 [Applications/Tor Browser]: Design TBA+Orbot configuration UI/UX
Tor Bug Tracker & Wiki
blackhole at torproject.org
Wed Apr 10 15:30:39 UTC 2019
#28329: Design TBA+Orbot configuration UI/UX
-------------------------------------------------+-------------------------
Reporter: sysrqb | Owner: tbb-
| team
Type: enhancement | Status:
| needs_review
Priority: Very High | Milestone:
Component: Applications/Tor Browser | Version:
Severity: Normal | Resolution:
Keywords: tbb-mobile, ux-team, TBA-a3, | Actual Points:
tbb-8.5-must-alpha, TorBrowserTeam201904 |
Parent ID: | Points:
Reviewer: | Sponsor:
| Sponsor8
-------------------------------------------------+-------------------------
Changes (by sysrqb):
* status: needs_revision => needs_review
Comment:
Replying to [comment:94 gk]:
> Replying to [comment:91 sysrqb]:
> > Replying to [comment:88 gk]:
>
> [snip]
>
> > >
> > > {{{
> > > final int expectedHeight = (int)
(currentWidth*imgHeight/imgWidth);
> > > final int expectedWidth = (int)
(currentHeight*imgWidth/imgHeight);
> > > }}}
> > > You already calculated the ratios and saved them in variables, no
need to
> > > calculate them again here (and elsewhere!).
> > >
> >
> > I deleted the ratio variables because I found the syntax confusing due
to additional type casting and needing more nested parentheses. This was
included in the accidental-fixup commit, but I can revert this change if
you think the ratio variables are more readable.
>
> Works for me. In that case please remove
> {{{
> final double imgDimensionRatioHeightWidth = imgHeight/imgWidth;
> final double imgDimensionRatioWidthHeight = imgWidth/imgHeight;
> }}}
Those should be deleted in the `fixup!` commit.
{{{
- final int expectedHeight = (int) (((double)
currentWidth)*imgDimensionRatioHeightWidth);
- final int expectedWidth = (int) (((double)
currentHeight)*imgDimensionRatioWidthHeight);
+ final int expectedHeight = (int)
(currentWidth*imgHeight/imgWidth);
+ final int expectedWidth = (int)
(currentHeight*imgWidth/imgHeight);
}}}
In any case, I pushed a new branch with these corrections, and I modified
the dense comment above the width/height conditional so it is clearer (I
hope). Branch `28329_30`.
For the onion size, I adding a little more logic for choosing the size. If
the image's width is greater than 600dp then set the max width at 600dp
and scale the height accordingly. However, if the the current width is
already near 600dp (+/- 100dp), then set the width at 400dp and scale the
height accordingly. I'm hoping this allows for a better experience on
lower-density/lower-resolution screens.
As for the space between the `about:tor` text and the url bar, I don't
know what it causing that. I haven't successfully reproduced it. We added
some code for preventing this by reloading the page when the chrome (url
bar) is rendered after bootstrapping completes. I noticed we reload the
page and allow Gecko to use the cache. I wonder if this is the bug, where
it is using the cached version instead of re-rendering it, but I don't
know why I can't reproduce it. In this new branch I forced bypass-cache
with reload, so I'm curious if this solves the problem.
In addition, I now have a spinning onion animation file we may be able to
use. I don't know if we'll be can get it into this release.
--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/28329#comment:95>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online
More information about the tbb-bugs
mailing list